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This 10 minute jump start to motion guide will take you through the basic steps of initializing your QuickSilver 

controller. We will then illustrate examples to expand your program.  

 

Connecting the Hardware 

Connect the motor to the controller using the motor interface cable (these typically have black over molded 

connectors and a ferrite bead). Connect the serial connections to the controller. DO NOT connect any serial 

adapters to their USB ports at this time. Make connections to the power supply, but do not yet connect the 

power supply input power.  

 

USB Serial Ports and Drivers 

Make sure to use latest drivers. These are available on our web page for downloading. The default windows 

drivers, in some instances, are several years old and are known to cause problems. Install the drivers first and 

then only connect the USB port when prompted by the installation software. Connecting the USB ports before 

installing the drivers will cause the default drivers to be installed. 

Hardware Requirements: 

• An unshared serial port capable of communicating at 57,600 Baud or better (USB to serial adapters ok). 

• QuickControl Software, which is free to download from 

http://www.quicksilvercontrols.com/QuickControl.html This will need an internet connection to install 

the .NET libraries from Microsoft. 

 

Install QuickControl 

Install QuickControl as follows:  Run the downloaded QuickControl installation program "Setup.exe". If it asks for 

administrator privileges, allow them. If the Microsoft run time libraries are not already installed on your system, 

you will be directed to download them from Microsoft.  

If you are running Windows 7 and newer please refer to Appendix A for instructions to configure QuickControl to 

run under compatibility mode.   
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10 Minutes to Motion  
 

Run QuickControl 1st Time  

With your hardware connected and your power off, run QuickControl. 

Start > Programs > QuickControl 

If your communication port has not yet been enabled (true for any first time users), QuickControl will prompt 

you to enable the Comm Port and initialize your servo.  

Click OK. 

Set Up Communication Port 

1. Click Setup under Toolbar Menu.  

2. Click on Comm port.  

3. Click on Modify. 

 

 

 

4. Select the desired Comm port under Comm port dropdown list. 

5. Setup Baud Rate and Protocol for default.  

6. Click OK.  

7. Verify that the Enable check box is selected and press OK.  

 

  

 

Initialization Wizard 
8. Launch Initialization Wizard from the Tools Menu. 

9. Click Open and select the appropriate initialization (Factory Default 

Initalization.qcp) file for your application and hardware. For these 

examples we are assuming a basic operation using one of our 

standard QCI servo motors. Different initializations are needed for 

open loop, and for DC motors and Voice Coils, as well as for CANopen 

operation. See Appendix B for alternative initialization scenarios. 

10. Enter the Motor Cable Length in feet. This can be found on the last 

two digits of the cable part 

number. For example, a QCI-C-

D15P-D15S-04 is a 4’ cable. If 

motor is directly connected to 

a controller (such as a QCI-D2-MG) enter 1 for the length.  

 



QuickControl: Quick Start to Motion 

 

 

QuickSilver Controls, Inc.      Page 4 of 13                      www.QuickSilverControls.com  

 

 

11. Press Download File To Device to initialize the servo using factory                           defaults.  

12. Unknown Device Wizard will now pop up. Power down and click Next. 

13. Power up device and verify that the red Comm light is flashing. If so, click Next. 

 

 

 

 

 

14. Select your Serial interface. Click Next. A window confirming 

device setup will then appear. Click Finish. 

15. A message will appear when the download is complete. Press 

OK to acknowledge message. 

16. Exit via the X box in the upper right hand corner.  

17. Initialization is complete! 

 

 

 

Control Panel 
 

 

18. Open Tools > Control Panel and the control panel 

window will open.  

19. To verify that the motor and controller are operational, 

left click and drag the purple slider bar up and down to 

produce clockwise and counter-clockwise motion. The 

speed scale box, just above the slider may be changed to 

allow a faster motion. The move commands may also be 

used to test particular motions. 

 

 
 

Create and Run First Program 
 

Move 8000 Counts at Power Up 
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We will create a new program that causes the servo to move 8000 encoder counts when it powers up. You 

should be polling and have device showing in the right panel to enable you to see the position of the motor. If 

your status is not green, press Scan Network on the Device Status Monitor.  

1. Create a new program by selecting New Program File from the File menu.  

File -> New Program File 

Your screen should look like this: 

 

 

We will now add a Move Relative Time Based (MRT) command to the user program. 

 

 

2. To add a command, go to Programs in the Toolbar menu 

and select Add Line.  

3. The Select Program Line dialog box will appear. Select the 

MOVE tab. 

4. Double click on MRT and the Edit Move dialog box will 

appear.  

 

 

 

5. Edit the move data as shown. This will produce a relative move of 8000 

counts in 1 second with a 100 millisecond ramp time at the start and 

end of the motion. Press Test to preview the motion. The motor 

should spin. 

6. Press the OK button to add this command to your program. 

7. Under the Program Info Toolbar on the left, press Download/Restart. 

QuickControl will download your program to the servo's non-volatile 

memory. It will then restart the controller and go 8000 counts in 1 

second.  You can press Restart to cause the program to execute again. 

8. The program you just wrote will execute every time the servo powers up.  

9. Select Save As from the File menu to name and save your program. 

10. Congratulations! You are a programmer. ☺  
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Stop a Move Using a Digital Input 

Note: if you do not have a physical switch, you can also simulate I/O using the Control Panel.  

Open Control Panel. On the lower right hand corner will be indicators for each of the I/O bits on the controller. 

Clicking on the I/O will set it to tri-state.  Holding the Shift button and clicking on the I/O will set the IO HIGH. 

Holding the Ctrl key and clicking on the I/O will clear the I/O LOW. The instructions are next to the indicators to 

help remind you. 

1. Double click the existing MRT command in your program. 

2. Press the Stop Condition button on the Edit box that pops up.  

 

3. Select the Standard tab.  

4. Select I/O #1 Condition and LOW/FALSE State.  This 

selection will cause your move to stop when I/O #1 is 

LOW.  

5. Press OK to save and exit. 

6. Press OK to exit the Edit Move Dialog box. 

7. Set I/O #1 HIGH and click the Download/Restart 

button on the Program Info Toolbar and verify the 

move stops when I/O #1 goes LOW.  

8. Press Restart and verify the program runs again. 

 

Start a Move Using a Digital Input 

1. We will now add a command that will cause the servo to wait until I/O #5 is LOW before executing our 

move.  

2. With the MRT command selected/highlighted, press the Insert button (top left) to insert a line above the 

selected line, in this case, above line 2. (Note:  pressing Add will add a line below the selected line). The 

Select Program Line dialog box will appear.  

3. Select the FLOW tab. 

4. Double-Click on the WBS - Wait on Bit State - command. This command will cause the servo to wait at the 

program line until the condition is met.  

 

 

5. Enter the data as shown. 

6. Press OK to add the command to the program. 

7. Set I/O #5 HIGH, and then click Download/Restart to run your 

program. Note, the servo does not move until I/O #5 goes LOW and 

will stop early if I/O #1 goes LOW.  
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Forever Loop  

1. Now we will add a command to repeat the program 

indefinitely.  

2. With the MRT command selected/highlighted, click the Add 

button.  

3. Select the FLOW tab. 

4. Select the JMP command. 

5. In the label field, enter the word “START” as shown on right. 

6. Press OK to exit the Edit Jump Command dialog box.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7. We have just added a command to jump to the program line with the label “START”. Add this label to line 

number 2 by clicking on the line 2 label cell and type START. The JMP command will now loop to line 2 after 

it finishes the move. 

8. With both I/O #1 and I/O #5 HIGH, Download/Restart the program. Verify the motor does not spin until I/O 

#5 goes LOW. Verify the motor executes its move until I/O #1 goes LOW.  

9. Save the program under a name of your choice. You can look at a fully documented version of the program 

by opening: …QCI Examples\ Using Inputs for Move Selection\Tutorial-Using an Input to Start and Stop a 

Move.qcp 



QuickControl: Quick Start to Motion 

 

 

QuickSilver Controls, Inc.      Page 8 of 13                      www.QuickSilverControls.com  

 

Expanding Your Program Basic Motion Commands 
 

There are four basic motion commands that are used to create simple motion profiles. These commands follow 

the same motion rules, but require different motion parameters. The result is a similar type of motion. The 

differences between the commands allow motion to be defined by relative or absolute distance, using velocity 

or time as the base. The commands pre-calculate the motion profile. The motion profile is subject to the 

maximum acceleration and velocity of the servo motor. A motion profile that the servo cannot numerically 

accomplish will cause a command error and the motion will not be executed. On the other hand, it is possible to 

program a motion profile that is numerically consistent, but requires more torque than available in the given 

servo.  

Relative Motion 

The Move Relative, Velocity Based (MRV) and Move Relative, Time Based (MRT) commands are both relative 

moves. Relative motion is distance based, meaning that the first parameter is the overall distance to move. The 

starting position when the motion begins is irrelevant and the shaft will simply rotate the specified number of 

counts. 

Absolute Motion 

The Move Absolute, Velocity Based (MAV) and Move Absolute, Time Based (MAT) commands are absolute 

moves. As long as the device is powered, it keeps track of its current location based on the zero point. The 

absolute position move is also based on the zero point. Please note that the zero point can be reset using the 

Zero Target and Position (ZTP) command, or moved/offset using the CLC “Sub Target Position” command.  

Absolute motion is position based, where the first parameter specified is the position to move to. The actual 

distance moved is the difference between the current position and the position specified in the command. 

Velocity Based Motion 

The MRV and MAV commands are velocity based. The second and third parameters are velocity and 

acceleration. The servo will use the specified acceleration to achieve the velocity, and the same acceleration to 

bring the servo to a halt. If the acceleration is not sufficient to reach the specified velocity before deceleration 

must begin, the profile will be triangular rather than trapezoidal. 

Note, acceleration and velocity must produce a ramp that is no more than a 7.86 seconds in duration for the 

move to be accepted. Slower ramps can be produced using the PMV command. 

 

 

 

 

 

 

 

Trapezoidal Motion 

Full S-Curve 

2 x Acceleration 

as Trap. Motion 

Full S-Curve 

Same Acceleration 

as Trap. Motion 

Velocity Based Motion and S-Curve 
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Velocity Control 

If an application requires only velocity control and no position designation, the Velocity Mode (VMP or VMI) 

commands should be used. VMP is the program type command, and VMI is the immediate type. The both 

Velocity Mode commands provide a “never-ending” motion. If no outside conditions interfere, the servo motor 

will continue to move at the specified velocity “forever”. (Note: if the final velocity is zero, the command will exit 

once zero velocity has been reached.)  This command requires two parameters, velocity, and acceleration. A 

SilverLode servo will achieve the specified velocity using the given acceleration, and remain at that velocity until 

commanded otherwise. In a multitasking environment, this command can override any other motion currently 

in progress. This provides an easy transition using a controlled deceleration to slow down or stop the servo. See 

Chapter 3 for more information on multitasking. 

Time Based Motion 

The MRT and MAT commands use time based parameters to create a motion profile. The second and third 

parameters are ramp time and total time. The total time specifies how quickly the move is to be completed. The 

ramp time sets the time to accelerate to velocity and the time to decelerate until it is stopped. The total time 

must be greater than twice the ramp time or errors will result and the move will not be executed. 

Note: maximum ramp time is 7.86 seconds. 

S-Curve Factor 

SCF determines the fraction of the acceleration/deceleration period that will be used to ramp up to and down 

from the needed acceleration (constant Jerk). A value of 0 defines a basic trapezoidal move, while a value of 

32767 causes the entire acceleration /deceleration period to be used. A value of 3277 uses 10 percent of the 

acceleration/deceleration time to transition to/from the desired acceleration, lowering the required Jerk 

accordingly. A 10 percent value thus increases the maximum acceleration needed by a timed move by 10 

percent, and the acceleration/deceleration time needed for a constant velocity/acceleration move by 10 

percent. 

A full s-curve will minimize the rate of change of acceleration (or jerk) for a trapezoidal motion. In a full s-curve 

time based move, the actual acceleration used is double that of a pure trapezoidal (zero s-curve) motion. In a 

velocity based move, the time to complete the move increases proportionally to the amount of s-curve 

specified. In order to have the full s-curve move complete in the same time as the trapezoidal move, the 

acceleration parameter must be doubled. The following chart shows a velocity based move with zero s-curve 

(trapezoidal), full s-curve, and full s-curve with the specified acceleration doubled. 

Significant reduction in jerk in the system may be attained by a 20% or 50% s-curve (for example), where the 

acceleration ramps up over a portion of the curve, then is held constant for a portion, and then is ramped down 

again, with the same process occurring for the deceleration portion of the curve. A 20% s-curve factor value   

only adds 20% to the acceleration in a time based move or 20% to the time in a velocity based move, but can 

significantly reduce the jerk at the start and end of the move.  The max value of the SCF command is 32767; a 

20% value would thus be set to 653 = 0.2*32767. 
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Basic Motion Commands & Jump Commands 
 

The purpose of this exercise is to get familiar with the basic MRV, JMP, and JOI commands. The servo will 

execute two moves depending on the state of the I/O #1 and I/O #3. The program runs in a continuous loop 

monitoring the two inputs.  

 

1. Make sure QuickControl is polling the device. Press the Scan Network button in the middle of the Device 

Status Monitor to start polling the device if polling is stopped. 

2. Select File → Open. Navigate to the “…\QCI Examples\Using Inputs for Move Selection\” folder and select 

the file “Two Inputs Two Moves with MRV.qcp”. 

3. Put I/O #1 and #3 in the HIGH state. If you do not have physical switches, open the control panel and follow 

the instructions for the I/O portion on the control panel. Following the “set” instructions (hold the shift key 

down and left click the given IO indicator box) will set the I/O to a high state, while the “clear” instructions  

(hold down the CTRL key and left click) will set the I/O to a low state. Verify both inputs are in the high state 

by looking at the Input status boxes just above the Scan Network button. A Green box indicates the I/O line 

(in this case an input) is in the HIGH state. A Red box indicates a LOW state. Take a moment to toggle the I/O 

switches up & down to see the Input status boxes change color as the inputs change state. 

4. Press the “Download/Restart” button on the Program Info Toolbar. Once the program is downloaded press 

the OK button. The program is now running. 

5. Toggle I/O #1 LOW, then back to HIGH. The device will execute a simple move. 

6. Toggle I/O #3 LOW, then back to HIGH. The device will execute a different move. Experiment with the I/O 

and notice the servo's motion. When finished close the active program. 

 

 

 

Basic Velocity Mode 

This exercise demonstrates the basic Velocity Mode, Program Mode (VMP) command. It illustrates how simple it 

is to have the device operate in a set velocity mode & stop on an Input trigger. 

 

1. Select File → Open. Navigate to “…\QCI Examples\ Moves – basic\Velocity Mode, Program Mode.qcp” 

2. Press the “Download/Restart” button to download and begin execution of the program. Once the program is 

downloaded press the OK button. 

3. The servo is now running in Velocity Mode. Notice the position counter window increasing the revolution 

count value as the device moves. Toggle I/O #5 LOW to stop motion. Press the Restart button to run again. 

When finished close the active program. 

 

This program contains only one command. It has all the parameters needed for simple motion control. 
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Creating, Downloading, and Running a Program in Qui ckControl ® 
 

In this exercise, a new program is created in QuickControl. It includes a short Move Relative, Velocity Based 

(MRV) move clockwise and a similar move counter-clockwise. I/O #1 can be triggered LOW to stop motion ay 

any time. 

 Creating a New Program 

1. Select New Program File from the File menu to open a blank new program template. 

2. Choose Add from the Program Info Toolbar to place a new program command in the list. 

3. Choose the Move tab and double-click on MRV (Move Relative, Velocity Based) command. 

4. Enter the following values for the first MRV move:  

Distance:   -10000 counts 

Acceleration:   1000 cps/s  

Velocity:    2000 cps 

*Acceleration parameters are rounded as QuickControl calculates the exact motion profile. 

5. Press the Stop Condition button. 

6. Choose the Standard tab of the Edit Stop Conditions box. Select I/O #1 for the Condition and use HIGH/TRUE 

as the State. 

7. Press the OK button twice to get back to the main QuickControl screen.  

8. Highlight the newly created Line 2 and choose Insert from the Program Info Toolbar. This will insert a new 

program command into the program list before the first MRV command on Line 2. 

9. Choose the Move tab and double-click on MRV (Move Relative, Velocity Based) command. 

10. Enter the following values for the second MRV move:  

Distance:   10000 counts 

Acceleration:    1000 cps/s  

Velocity:    2000 cps 

11. Press the Stop Condition button. 

12. Choose the Standard tab of the Edit Stop Conditions box. Select I/O #1 for the Condition and use LOW/FALSE 

as the State. 

13. Press the OK button twice to get back to the main QuickControl screen. 

Downloading and Running the Program 
14. Before running the program, make sure I/O is ON or HIGH. 

15. Press Download/Restart on the Program Info Toolbar. This function will Download the program into the NV 

memory and restart the servo which will run the program. The program will only run once per Restart! 

16. While the program is running, trigger I/O #1 to stop the move before the motion completes. Press the 

Restart button to run the program again. 

Saving the New QCP File 

17. Using the File menu click on Save As. This will open a standard file browser window where the program can 

be named and saved to the computer.   
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Appendix A 

Configure for Windows 7 

If you are getting a message like the one shown on the 

right and/or unable to modify COMM port settings, you 

will need to configure QuickControl to run in 

compatibility mode. 

 

 

 

 

1. Browse to the QuickControl directory 

Computer > Disk Drive > Program Files (x86) 

> QuickControl 

2. Right-click on the QuickControl 

executable application and select on 

properties. 

 

 

 

 

 

 

 

 

 

3. Select the Compatibility tab. 

4. Check the “Run this program in compatibility mode for:” box. 

5. Select Windows XP (Service Pack 3). 

6. Click OK. Restart QuickControl. You should now be able to run 

QuickControl.  
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Appendix B 

Initialization File 

The initialization file has a starting address of 0, thus, is the first program that’s loaded and executed. The 

initialization file is a program that defines controller configuration. For example,  

• Motor limits (i.e. torque limits, error limits, etc.),  

• Controller parameters (unit ID, communication parameters, etc.) 

• Servo tuning parameters.  

When programming our servo controllers in combination with our I-Grade servo motors, download our standard 

default initialization file which can be found in the following directory:  

C:\Program Files\QuickControl\QCI Initialization\Factory Default Initialization.qcp 

If the servo controller supports CANopen download our CANopen initialization file. This initialization file 

configure a default CANopen ID and CANopen baud rate:  

 C:\Program Files\QuickControl\QCI Initialization\Factory Default Initialization - CAN.qcp 

In addition to drive our I-Grade servo motors, the SilverSterling controller line is designed to drive 3rd party DC 

brush motor, voice coil motors, and 3-phase brushless motors. Please contact QCI support for special 

initialization files.  

Application Note - DC Brush Motor: QCI-AN068 - Transmotec DC motors with Encoder Feedback 

Application Note - Voice Coils: QCI-AN066 - BEI Voice Coil Motors with Analog Feedback 

 


